РЕГИСТРАЦИЯ
Гость
Вход не выполнен.

Проблема со сниппетами

Nevr

  • Участник
  • Посетитель
  • 22
  • 0
  • Жалоб нет
  • Регистрация:
#1

Версия движка 5.2
Создал сниппет "AddToBuy", внутри только php-код, открывающихся и закрывающихся тегов (<? и ?&gt;) нет внутри сниппета.
Вставляю в шаблон код {[AddToBuy]} - в результате он просто мне выводит текст "{[AddToBuy]}" на странице и всё, никакой замены на php-код из сниппета не происходит нигде.
Я что-то неправильно понимаю, делаю не так, или это баг (в багтрекере не нашёл такого вопроса - может, проглядел...)?


MAX555

  • O, Великий ретранслятор!
  • Посетитель
  • 389
  • 3
  • Жалоб нет
  • Регистрация:
#2

А вы чистили кэш? 


http://tvmax.96.lt

Nevr

  • Участник
  • Посетитель
  • 22
  • 0
  • Жалоб нет
  • Регистрация:
#3

Да, кэш чистил.
Всё, понял - всё просто.
Странная проблема: называл сниппеты с большой буквы. Вызывал тоже с большой буквы - не работает. Вызвал с маленькой - работает. Все буквы - латиница, цифр или ещё чего-то нет... Где-то неправильно восприятие регистров настроено (поскольку создать такой же по названию с маленькой буквы не дал - сказал есть такой).


MrBoriska

  • Мастер
  • Администратор
  • 285
  • 11
  • Жалоб нет
  • Регистрация:
#4
Nevr пишет:
Всё, понял - всё просто.Странная проблема: называл сниппеты с большой буквы. Вызывал тоже с большой буквы - не работает. Вызвал с маленькой - работает. Все буквы - латиница, цифр или ещё чего-то нет... Где-то неправильно восприятие регистров настроено (поскольку создать такой же по названию с маленькой буквы не дал - сказал есть такой).

Спасибо! Будем разбираться)