РЕГИСТРАЦИЯ
Гость
Вход не выполнен.

ошибка редактирования коментариев

jevgenij

  • Участник
  • Посетитель
  • 13
  • 0
  • Жалоб нет
  • Регистрация:
#1

вот наткнулся на ошибку редактирования материалов

Parse error: syntax error, unexpected '[' in C:\OpenServer\domains\test1.ru\sys\inc\includes\edit_comment_form.php on line 22

Отредактировано автором в

MrBoriska

  • Мастер
  • Администратор
  • 285
  • 11
  • Жалоб нет
  • Регистрация:
#2

jevgenij, у тебя старая версия системы. в новой уже не существует папки includes


jevgenij

  • Участник
  • Посетитель
  • 13
  • 0
  • Жалоб нет
  • Регистрация:
#3

вот так чудо на последней версии все работает а на стабле версии баг ------  круто постарались Админка порадовала выглядит очень круто да и движок заметно изменился  (так держать) :)


Отредактировано автором в

modos189

  • Мастер
  • Администратор
  • 208
  • 6
  • Жалоб нет
  • Регистрация:
#4

Если на 22 строке указанного файла заменить

$comment = $this->AddFields->mergeSelect(array($comment), 'comments')[0];

на

$comment = $this->AddFields->mergeSelect(array($comment), 'comments');
$comment = $comment[0];

то проблема решается?


MrBoriska

  • Мастер
  • Администратор
  • 285
  • 11
  • Жалоб нет
  • Регистрация:
#5
jevgenij пишет:
на последней версии все работает а на стабле версии баг

А у тебя точно последняя стабильная версия? Ты откуда качал? Прост релиз был 2015-01-08, но последние в него правки вносились аж до 2015-07-17. 
Вот: https://bitbucket.org/atom-m/cms/commits/branch/release%2Fatom-m-4
И скачать можно по ссылке: https://bitbucket.org/atom-m/cms/get/release/atom-m-4.zip

Хотя баг наверно все же есть в нем. 

Кстати если правка, предложенная modos189, сработает, то у тебя версия php старенькая. Ставь 5.4 . На 5.3 мы уже не пашем.


Отредактировано автором в